[Bug 667] New: <patch> element support for download and uncompression

Kevin P. Fleming kpfleming at backtobasicsmgmt.com
Sat Sep 20 06:37:02 PDT 2003


Neven Has wrote:

> Although we have way too many syntax versions with smaller changes and
> that's really confusing.   We should probably wait for more syntax
> changes before we create a new version.
> 

Can we support a three-level DTD version numbering scheme? For 
example: 3.0 -> 3.1 -> 3.1.5?

If so, we could treat handlers with two-level version numbers as if 
the number ended with a wildcard ("3.1.*"), meaning this handler will 
accept any DTD version beginning with 3.1. Only when we make an 
incompatible change would a new version of the handler get a 
three-level DTD version number, ("3.1.5"), in which case it would be 
willing to accept 3.1.<anything above 4>.

Thoughts?




More information about the alfs-log mailing list