cvs commit: ALFS/docs/syntax_doc/alfs_dtd elem_version.xml

jwrober at linuxfromscratch.org jwrober at linuxfromscratch.org
Fri Feb 6 20:42:49 PST 2004


jwrober     04/02/06 21:42:49

  Modified:    docs/syntax_doc/alfs_dtd elem_version.xml
  Log:
  cleanup to DTD 3.1
  
  Revision  Changes    Path
  1.6       +29 -28    ALFS/docs/syntax_doc/alfs_dtd/elem_version.xml
  
  Index: elem_version.xml
  ===================================================================
  RCS file: /home/cvsroot/ALFS/docs/syntax_doc/alfs_dtd/elem_version.xml,v
  retrieving revision 1.5
  retrieving revision 1.6
  diff -u -r1.5 -r1.6
  --- elem_version.xml	4 Nov 2003 03:07:50 -0000	1.5
  +++ elem_version.xml	7 Feb 2004 04:42:49 -0000	1.6
  @@ -6,14 +6,15 @@
   <title>Syntax</title>
   
   <synopsis>
  -<!ELEMENT version       (#PCDATA)>
  +<!ELEMENT version        (#PCDATA)>
   <!ATTLIST variable
  -          condition (eq|ne|gt|ge|lt|le) #REQUIRED>
  +          condition      (eq | ne | gt | ge | lt | le) #REQUIRED>
   </synopsis>
   
  -<para>This element occurs in the elements
  -<link linkend="elem_utilizes">utilizes</link> and
  -<link linkend="elem_requires">requires</link>.
  +<para>This element occurs in the elements :  
  +<xref linkend="elem_package"/>  |  
  +<xref linkend="elem_utilizes"/>  |  
  +<xref linkend="elem_requires"/>
   </para>
   
   </sect2>
  @@ -21,45 +22,45 @@
   <sect2>
   <title>Description</title>
   
  -<para>The element <token>version</token> describes a constraint
  -on the version of an utilized/required package.</para>
  +<para>The element <filename>version</filename> describes a constraint on
  +the version of an utilized or required package.</para>
   
  -<para>The condition is satisfied if the comparison specified
  -by the attribute <token>condition</token> applies between the
  +<para>The condition is satisfied if the comparison specified by the
  +attribute <filename>condition</filename> applies between the
   actual version value of the package, and the value specified
   as the content of the element.</para>
   
  -<para>When performing the comparison, the sequences of digits are
  -compared numerically, while all the other characters are compared using
  +<para>When performing the comparison, the sequences of digits are compared
  +numerically, while all the other characters are compared using
   their codes. Moreover, any substring is greater than the empty string.</para>
   
  -<para>That means, for instance, that 2.0.10 is greater than 2.0.9,
  -2.0a is greater than 2.0 and 2.10 is greater than 2.1a.</para>
  +<para>That means, for instance, that 2.0.10 is greater than 2.0.9, 2.0a is
  +greater than 2.0 and 2.10 is greater than 2.1a.</para>
   
   <para>Note that the algorithm fails for reasonable interpretations of
   version numbers like 3.0 and 3.0beta. Intuitively, 3.0 is greater than
  -3.0beta, but the algorithm returns the opposite.
  -To indicate for instance that
  -the required package must have a version greater than 3.0, one would need
  -two <token>version</token> elements, to require that the actual version be greater
  -than or equals to 3.0, and that it be different from 3.0beta.</para>
  +3.0beta, but the algorithm returns the opposite.  To indicate
  +for instance that the required package must have a version greater than
  +3.0, one would need two <filename>version</filename> elements, to require
  +that the actual version be greater than or equal to 3.0, and that it be
  +different from 3.0beta.</para>
   
   </sect2>
   
   <sect2>
   <title>Examples</title>
   
  -<programlisting>
  -<packageinfo>
  -    <requires>
  -        <name>guile</name>
  -	<version condition="ge">1.5<version>
  -    </requires>
  -</packageinfo>
  -</programlisting>
  +<userinput><screen><packageinfo>
  +	<requires>
  +		<name>guile</name>
  +		<version condition="ge">1.5</version>
  +	</requires>
  +</packageinfo></screen></userinput>
   
  -<para>This signifies that the package being build requires
  -guile in its version 1.5 or more recent.</para>
  +<para>This signifies that the package being build requires guile in its
  +version 1.5 or more recent.</para>
  +
  +<para>There is no equivalent Bash script example for this element.</para>
   
   </sect2>
   
  
  
  



More information about the alfs-log mailing list