r2159 - jhalfs/trunk

manuel at linuxfromscratch.org manuel at linuxfromscratch.org
Sat Nov 5 02:59:23 PST 2005


Author: manuel
Date: 2005-11-05 03:59:23 -0700 (Sat, 05 Nov 2005)
New Revision: 2159

Modified:
   jhalfs/trunk/jhalfs
Log:
The download of module-init-tools-testsuite package is required only if the optional test suites will be run.

Modified: jhalfs/trunk/jhalfs
===================================================================
--- jhalfs/trunk/jhalfs	2005-11-03 22:43:34 UTC (rev 2158)
+++ jhalfs/trunk/jhalfs	2005-11-05 10:59:23 UTC (rev 2159)
@@ -171,8 +171,12 @@
   grep "\-version" $BOOK/general.ent | sed -e 's@<!ENTITY @@' -e 's@">@"@' \
   -e '/generic/d' >> packages
   echo `grep "glibc" packages | sed 's at glibc@&-linuxthreads@'` >> packages
-  echo `grep "module" packages | sed 's at tools@&-testsuite@'` >> packages
   echo `grep "udev-config-file" $BOOK/general.ent | sed -e 's@<!ENTITY @@' -e 's@">@"@'` >> packages
+  # Download the module-init-tools-testsuite package only 
+  # if the test suite will be run.
+  if [ "$TEST" = "1" ] ; then
+    echo `grep "module" packages | sed 's at tools@&-testsuite@'` >> packages
+  fi
   # If we are buildind the UTF-8 branch, the glibc-libidn package is required
   if grep -q "man-db-version" $BOOK/general.ent ; then
     echo `grep "glibc" packages | sed 's at glibc@glibc-libidn@'` >> packages




More information about the alfs-log mailing list