r2226 - jhalfs/trunk

manuel at linuxfromscratch.org manuel at linuxfromscratch.org
Sun Nov 27 02:07:18 PST 2005


Author: manuel
Date: 2005-11-27 03:07:17 -0700 (Sun, 27 Nov 2005)
New Revision: 2226

Modified:
   jhalfs/trunk/jhalfs
Log:
The glibc-linuxtrheads and module-init-tools-testsuite packages are required only for 6.1.1

Modified: jhalfs/trunk/jhalfs
===================================================================
--- jhalfs/trunk/jhalfs	2005-11-26 19:35:10 UTC (rev 2225)
+++ jhalfs/trunk/jhalfs	2005-11-27 10:07:17 UTC (rev 2226)
@@ -221,16 +221,19 @@
   for i in patches packages ; do rm -f $i ; done
   grep "\-version" $BOOK/general.ent | sed -e 's@<!ENTITY @@' -e 's@">@"@' \
   -e '/generic/d' >> packages
-  echo `grep "glibc" packages | sed 's at glibc@&-linuxthreads@'` >> packages
   # Download the vim-lang package if it must be installed
   if [ "$VIMLANG" = "1" ] ; then
     echo `grep "vim" packages | sed 's at vim@&-lang@'` >> packages
   fi
   echo `grep "udev-config-file" $BOOK/general.ent | sed -e 's@<!ENTITY @@' -e 's@">@"@'` >> packages
-  # Download the module-init-tools-testsuite package only 
-  # if the test suite will be run.
-  if [ "$TEST" = "1" ] ; then
-    echo `grep "module" packages | sed 's at tools@&-testsuite@'` >> packages
+  # This two packages are needed only for 6.1.1
+  if [ "$LFSVRS" = "6.1.1" ] ; then
+    echo `grep "glibc" packages | sed 's at glibc@&-linuxthreads@'` >> packages
+    # Download the module-init-tools-testsuite package only 
+    # if the test suite will be run.
+    if [ "$TEST" = "1" ] ; then
+      echo `grep "module" packages | sed 's at tools@&-testsuite@'` >> packages
+    fi
   fi
   # If we are buildind the UTF-8 branch, the glibc-libidn package is required
   if grep -q "man-db-version" $BOOK/general.ent ; then




More information about the alfs-log mailing list