Building LFS/BLFS on USB.

Tijnema ! tijnema at
Thu Apr 5 07:56:22 PDT 2007


I want to build a LFS/BLFS system on a USB pendrive. I have a 1GB
pendrive, from which i want to boot through Floppy drive. What i have
now is a LFS system installed on the USB stick. I created a very small
kernel that is about 990K, so that it fits on my floppy :) It has USB
storage drivers and ext2 drivers built in. I installed syslinux on my
floppy, and it does boot the floppy, then i tell syslinux to boot the
small kernel, and load an initrd file. I created this myself so i'm
not sure if i did it right.
This is the part of my syslinux.cfg file:

KERNEL kern26
APPEND initrd=initrd.gz root=/dev/ram0 init=/etc/start

First I didn't had the root=/dev/ram0 item, but it doesn't make any
difference. It also doesn't make any sense if i replace it with
root=/dev/rd/0 as some sites suggest. After the kernel loads, and the
initrd.gz is uncompressed. It gives me the error:

No filesystem could mount root, tried:
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

So what did i do wrong? It should mount the initrd file and start
/etc/start script in the initrd file right? There i've written a
script to mount USB and do the work there. But it seems that the
/etc/start script is never executed because it doesn't mount the
initrd file?
What me confuses is that it didn't try to mount any filesystem, as
there isn't anything after the tried:

Any ideas?


ps. Using the kernel from LFS SVN.

More information about the blfs-support mailing list