compiling digikam-0.9.2

david567 david567 at windstream.net
Wed Aug 29 04:22:31 PDT 2007


alberto hernando wrote:
> Hi.
> 
> The problem is in jasper. Digikam believes that it isn't installed, but it
> is. I've tried both 1.700 and 1.900 with the same result. Looking at
> config.log (in digikam), I have this:
> 
> configure:36876: checking for jas_init in -ljasper
> configure:36911: gcc -o conftest -std=iso9899:1990 -W -Wall
> -Wchar-subscripts -W
> shadow -Wpointer-arith -Wmissing-prototypes -Wwrite-strings
> -D_XOPEN_SOURCE=500
> -D_BSD_SOURCE -O2  -O3 -march=athlon-tbird -pipe -ffast-math
> -fomit-frame-pointe
> r -fPIC -Wformat-security -Wmissing-format-attribute  -DQT_THREAD_SUPPORT
> -D_RE
> ENTRANT      conftest.c -ljasper -ljasper  >&5

It looks like '-ljpeg -lm' need to be added to the configure flags for 
this conftest, somewhere near line 36900.  I have to go to work now,  If 
you don't have it hacked when I get home,  I'll look at it.

snip
> jpg_enc.c:(.text+0x5c8): undefined reference to `jpeg_destroy_compress'
> /usr/lib/gcc/i686-pc-linux-gnu/4.1.2/../../../libjasper.a(jas_cm.o): In
> function
>  `jas_cmshapmatlut_set':
> jas_cm.c:(.text+0xb5e): undefined reference to `pow'
> collect2: ld returned 1 exit status

---
David Jensen




More information about the blfs-support mailing list