[blfs-support] Google Gadgets

Bruce Dubbs bruce.dubbs at gmail.com
Sun Dec 2 09:40:21 PST 2012


brown wrap wrote:

> From: Chris Staub <chris at beaker67.com>
> To: brown wrap <gramos at yahoo.com>; BLFS Support List <blfs-support at linuxfromscratch.org>
> Sent: Saturday, December 1, 2012 10:01 PM
> Subject: Re: [blfs-support] Google Gadgets
>
> On 12/01/2012 11:06 PM, brown wrap wrote:
>> Has anyone tried installing Google Gadgets? It is listed and an optional
>> package under KDE-Workspace. The project says it has been discontinued
>> and the last update was in 2010.
>
> What about it? Are you having problems installing it?

Don't post after the footer.  It makes replying more difficult.
------

Yes, I tried installing it. I have to include at lot, to get back to the 
error:

  /usr/include/glib-2.0/glib/gnode.h:28:2: error: #error "Only <glib.h> 
can be included directly."
In file included from /usr/include/glib-2.0/glib/gnode.h:34:0,
                  from /usr/include/glib-2.0/glib/glist.h:35,
                  from /usr/include/glib-2.0/glib/ghash.h:35,
                  from ../../../ggadget/gtk/main_loop.cc:19:
/usr/include/glib-2.0/glib/gmem.h:28:2: error: #error "Only <glib.h> can 
be included directly."

Edit ggadget/gtk/main_loop.cc, line 19 and just include glib.h.

-------
../../../ggadget/gtk/main_loop.cc: In constructor 
'ggadget::gtk::MainLoop::Impl::Impl(ggadget::MainLoopInterface*)':
../../../ggadget/gtk/main_loop.cc:62:7: error: 'void 
g_thread_init(gpointer)' is deprecated (declared at 
/usr/include/glib-2.0/glib/deprecated/gthread.h:259) 
[-Werror=deprecated-declarations]

You also need to remove -Werror from the Makefile.

   -- Bruce



More information about the blfs-support mailing list