[blfs-support] unable to install apt on LFS

James Pinto james.pinto at phoenixfusion.in
Mon Dec 3 10:40:04 PST 2012


On Mon, Dec 3, 2012 at 9:35 PM, Fernando de Oliveira
<famobr at yahoo.com.br> wrote:
>
> --- Em seg, 3/12/12, Ken Moffat escreveu:
>
> > De: Ken Moffat
> > Assunto: Re: [blfs-support] unable to install apt on LFS
> > Para: "BLFS Support List"
> > Data: Segunda-feira, 3 de Dezembro de 2012, 12:45
> > On Mon, Dec 03, 2012 at 07:38:21AM
> > -0800, Fernando de Oliveira wrote:
> > > Still sending html. Either you do not understand what
> > html is, do not care about it or do not know how to disable
> > it. I am tired of reformatting your posts.
> > >
> > > Send the output of
> > >
> > >     ls -l /lib/libc6.so
> > >
> > > []s,
> > >
> > > Fernando
> >
> >  With respect, Fernando, this libc dependency is nothing to
> > do with
> > what is actually installed.  The hint has an attached
> > status file,
> > the contents of that (if he followed the hint and installed
> > it)
> > appear to not work to show that the dependency is met.
>
> I Know. I thought this at first, but was trying to see how far we could
> help him to get what he wanted, and one of his problems is libc6.
>
> I have had in the past problem with a link to libc6, more than one time,
> when trying to install lfs-tools, one time I documented in the list.
>
> Perhaps before starting trying to help him I should have warned about
> this point of the age of the tip, in the beginning.
>
>
> []s,
> Fernando
> --
> http://linuxfromscratch.org/mailman/listinfo/blfs-support
> FAQ: http://www.linuxfromscratch.org/blfs/faq.html
> Unsubscribe: See the above information page

I am aware that this hint is very old and there is no updated hint..
Also I have the dpkg folder in /var/lib/ and not /var

so I substitute the /var/dpkg with var/lib/dpkg in the touch commands
in the hint.

I have updated he status file with many new packages at least gcc
gnupg etc are mentioned in the status file.

The output asked for
ls -l /lib/libc6.so
lrwxrwxrwx 1 root root 14 Dec  3 22:50 /lib/libc6.so -> /lib/libc.so.6

It dint exist I ad to create a symlink

I tried installig the eglibc package even that doesnt work.

Regards
--
James Earnest Pinto
Director/CEO
Phoenix Fusion
www.phoenixfusion.in



More information about the blfs-support mailing list