[blfs-support] problem with the drm nouveau kernel modules

Bruce Dubbs bruce.dubbs at gmail.com
Mon Jul 2 09:04:48 PDT 2012


John Burrell wrote:
>
>>
>> I'm not sure which card you have.
> It's a GeForce 8700M GT apparently.
>>
>
> I had to add nomodeset as a kernel parameter to get the machine to boot and avoid the cycling color screens.
>
>> You do have to be careful when building the kernel not to include nvidia
>> drivers.
> There is nothing with *NVIDIA*=(y/m) set in the .config file
>>
>> You might want to post the critical parts of Xorg.0.log and xorg.conf.
>> For instance:
> I have this in /etc/X11/xorg.conf.d/20-nouveau.conf
>
> Section "Device"
>      Identifier "Nvidia card"
>      Driver "nouveau"
> EndSection

What happens if you change to the "nv" driver?

> Here are the critical bits of /var/log/Xorg.0.log
>
> [    84.069] (II) LoadModule: "nouveau"
> [    84.069] (II) Loading /usr/lib/X11/modules/drivers/nouveau_drv.so
> [    84.085] (II) NOUVEAU driver
> [    84.085] (II) NOUVEAU driver for NVIDIA chipset families :
> [    84.085]    RIVA TNT        (NV04)
> [    84.085]    RIVA TNT2       (NV05)
> [    84.085]    GeForce 256     (NV10)
> [    84.085]    GeForce 2       (NV11, NV15)
> [    84.085]    GeForce 4MX     (NV17, NV18)
> [    84.085]    GeForce 3       (NV20)
> [    84.085]    GeForce 4Ti     (NV25, NV28)
> [    84.085]    GeForce FX      (NV3x)
> [    84.085]    GeForce 6       (NV4x)
> [    84.086]    GeForce 7       (G7x)
> [    84.086]    GeForce 8       (G8x)
> [    84.086]    GeForce GTX 200 (NVA0)
> [    84.086]    GeForce GTX 400 (NVC0)
> [    84.086] (--) using VT number 7

> Fatal server error:
> [    84.262] no screens found

> lsmod shows the nouveau module is loaded, along with a few dependent modules.
>
> Any idea why drm doesn't detect the device?

For some reason the nouveux driver is not recognizing your card.  What 
does lspci say about your video HW?

   -- Bruce






More information about the blfs-support mailing list