[blfs-support] KDELIBS-4.8.4 cmake error

Ragnar Thomsen rthomsen6 at gmail.com
Wed Jul 4 13:20:53 PDT 2012


On Wednesday 04 July 2012 13:05:16 Bruce Dubbs wrote:
> Ragnar,  I'm having the same problem with 4.8.3.  I do have the links:
> 
> $ ls -l /opt/kde4/share/
> total 0
> lrwxrwxrwx 1 root root 17 Jul  1 13:37 dbus-1 -> /usr/share/dbus-1
> lrwxrwxrwx 1 root root 19 Jul  1 13:37 polkit-1 -> /usr/share/polkit-1
> 
> I'm using Polkit-0.106 and Polkit-Qt-0.103.0.  The .pc files seem to be
> in the right location and PKG_CONFIG_PATH is right.
> 
> Adding -DPOLKITQT-1_INSTALL_DIR=$KDE4_PREFIX fixed it for me, but I
> don't know why cmake is not picking it up automatically.

It seems that when installing polkit-qt, the variable:
POLKITQT-1_INSTALL_DIR
 in the cmake file:
/opt/kde4/lib/cmake/PolkitQT-1/PolkitQt-1Config.cmake
doesn't get set for you and Tony. This leads to the cmake-failure for kdelibs.

Looking at the PolkitQt-1Config.cmake.in file, the variable should get set to 
whatever CMAKE_INSTALL_PREFIX is. And since we set this variable in the build 
instructions for polkit-qt, I can't understand why the cmake file isn't 
generated correctly.

I can't replicate this on my machine. I tried reinstalling both polkit and 
polkit-qt, but the variable always gets set correctly for me.

Can somebody (Armin...?) try building polkit-qt and see if the variable gets 
set correctly?

-Ragnar-



More information about the blfs-support mailing list