[blfs-support] OpenSSH-6.0p1 configure: error: *** Can't find recent Openssl libcrypto

Yongbiao Long longyongbiao at gmail.com
Fri Jul 13 20:03:02 PDT 2012


Helllo, I followed the instructions from
http://www.linuxfromscratch.org/blfs/view/svn/postlfs/openssh.html
to build OpenSSH-6.0p1, but failed at the 'configure' step. The error
message showed 'Can't find recent Openssl libcrypto'.

Before I try to build OpenSSH-6.0p1, I've successfully installed
OpenSSL-1.0.1c, Linux-PAM-1.1.5 and TCP Wrappers-7.6.

The blfs book says:
       OpenSSH is very sensitive to changes in the
       linked OpenSSL libraries. If you recompile
       OpenSSL, OpenSSH may fail to start up. An
       alternative is to link against the static OpenSSL
       library. To link against the static library, execute
       the following command:
         sed -i 's at -lcrypto@/usr/lib/libcrypto.a -ldl@' configure

I found if I don't run this command, there would be no errors in
'configure', and no FATAL errors in the output of the test suite.

What seems to be the problem?

-- 
Best Regards



More information about the blfs-support mailing list