[blfs-support] dbus error when running make on at-spi2-atk-2.4.0

James Pinto james.pinto at phoenixfusion.in
Thu Jul 19 01:08:56 PDT 2012


Hi I booted into lfs got the dbus- daemon running (system wide)  and tried
the command again but istill get the same error even while installing
at-spi2-core-2.4.2 I get the same error while running make check.

Im just unable to move ahead installing gnome because of this, I have been
stuck here for 2 days now, can seem to fix this

Please help

Regards
James

On Wed, Jul 18, 2012 at 9:08 PM, Bruce Dubbs <bruce.dubbs at gmail.com> wrote:

> James Pinto wrote:
>
> > I think I know what the problem might be
> > Please correct me if Im wrong
> >
> > I read the following here
> > http://www.linuxfromscratch.org/blfs/view/svn/general/dbus.html (blfs
> book
> > online)
> >
> > Note that this boot script only starts the system-wide D-Bus daemon.
> >
> > So I think I need to Add *dbus-launch* to the line in the ~/.xinitrc file
> > and then boot into the LFS system instead of running these commands from
> > chroot on the host system....
> >
> > So I think the dbus daemon wasnt started...
> >
> > Im I right?
>
> Please trim the non-relevant portions of your posts.
>
> The system-wide dbus daemon is normally started at boot time after you
> go to the blfs bootscripts package and run make install-dbus.  If you
> want to start in the same session without rebooting, run the script as
> the root user:
>
> # /etc/init.d/dbus start
>
> If you are just trying to get up a basic Xorg system running twm for
> initial testing, then I don't think dbus is needed at all for testing.
> My basic ~/.xinitrc looks like:
>
>   $ cat .xinitrc
> # Begin .xinitrc file
> xterm  -g 80x40+0+0   &
> xclock -g 100x100-0+0 &
> exec twm
>
> If you have a problem, there are two approaches I use.  First, try
> Ctrl-Alt-F2 to see if you can get a console login.  The second is to
> have the sshd daemon running and ssh into the system from another
> computer and look at what processes are running and the contents of
> Xorg.log.0, etc.
>
> Note that in the current default twm/Xorg server, the big X cursor does
> not get displayed until you click the mouse.
>
>    -- Bruce
>
>
>
> --
> http://linuxfromscratch.org/mailman/listinfo/blfs-support
> FAQ: http://www.linuxfromscratch.org/blfs/faq.html
> Unsubscribe: See the above information page
>



-- 
James Earnest Pinto
Director/CEO
*Phoenix Fusion*
www.phoenixfusion.in
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxfromscratch.org/pipermail/blfs-support/attachments/20120719/d36b843f/attachment.html>


More information about the blfs-support mailing list