[blfs-support] Gtk+-2.24.10 and Gtk+-3.4.1

Andrew Benton andy at benton.eu.com
Fri May 4 03:56:21 PDT 2012


On Fri, 04 May 2012 10:27:52 +0100
"Armin K." <krejzi at email.com> wrote:

> --enable-gtk2-dependency removes that conflict.

That's interesting. Is that for Gtk 3? We don't want to make Gtk 2 a
required dep of Gtk 3 so we couldn't make that option the default. We
could put a switch on the configure line that tests if Gtk 2 is
installed. Something like:

./configure --prefix=/usr --sysconfdir=/etc \
             $(pkg-config --exists gtk+-2.0 &&
             echo --enable-gtk2-dependency) &&
make

Andy



More information about the blfs-support mailing list