[blfs-support] gcc-4.5.1 (BLFS) vs. gcc-4.7.0 (LFS)

Andrew Benton andy at benton.eu.com
Sun May 6 17:45:50 PDT 2012


On Mon, 07 May 2012 00:49:37 +0100
alex lupu <alupu01 at gmail.com> wrote:

> My latest build (make) of the Chrome browser failed with
> apparently a gcc (actually, g++) error of some sort:
> 
> "...
> Please submit a full bug report, ...
> See <http://gcc.gnu.org/bugs.html> for instructions. ..."
> 
> I've had gcc-4.5.1 (in good standing) for quite a while.
> Rather than going through the big effort, uncertainty and
> probably the futility of submitting a bug report,
> I'm thinking about just upgrading to gcc-4.7.0 (the latest
> as of this writing), thereby killing as many as two birds
> (in the ideal outcome).
> 
> QUESTIONS
> 1.  Mostly theoretical.  Why this dissimilarity between
> LFS and BLFS versions?

I think the version of GCC in BLFS is neglected because none of the
current editors use any of those compilers. I just need a C and C++
compiler so the GCC installed in LFS is fine for me. 

If I were you I'd install GCC-4.7 with the configure switches from
chapter 6 of current LFS. Unless you need fortran or whatever, in which
case, do you want to volunteer to update the BLFS page ;)

Andy



More information about the blfs-support mailing list