[blfs-support] MesaLib take about 18 SBU on my box.

Ken Moffat zarniwhoop at ntlworld.com
Thu May 24 07:22:45 PDT 2012


On Wed, May 23, 2012 at 10:39:18PM +0100, Ken Moffat wrote:
> On Thu, May 24, 2012 at 03:36:38AM +0800, xinglp wrote:
> > May be this reason, I lost "ldconfig" in Xorg Libraries.
> > I'll try it tomorrow, and feed back
> 
>  I think you mean that you did not run ldconfig after each library
> was installed ?  If so, any error would happen when ld failed to
> find the library, and you would get a build failure.  So, I doubt
> this is the problem (although it is, theoretically, possible that
> xorg-server could fail to link).
> 
>  Either way, running ldconfig when you encounter a failure to link
> will pick up all the now-existing libraries it did not know about.
> 
>  Certainly, we used to have to run ldconfig for many (or all) of the
> libraries when monolithic xorg (6.8 ?) was first broken into the
> modular version, and I still do that.
> 
>  So, I need to remove the 'ldconfig' steps on my next build (I'm now
> on 7.7-rc, so *if* they are no longer necessary for me, they might
> still be needed in 7.6) and test this.  Thanks for rousing my
> interest, I'm *so* glad I said I had no plans to upgrade anything
> else on BLFS at the moment ;-)
> 
 It would have been better if I checked what I actually do, instead
of relying on my memory :)  The only place in my scripts to build
Xorg where I run ldconfig is for llvm.

ĸen
-- 
das eine Mal als Tragödie, das andere Mal als Farce



More information about the blfs-support mailing list