[blfs-support] gstreamer versions question

Simon Geard delgarde at ihug.co.nz
Thu May 9 03:35:11 PDT 2013


On Thu, 2013-05-09 at 11:04 +0100, lux-integ wrote:
> I dont want to do parallel builds  so the question then becomes:-
> 
> "will gstreamer-dependent-stuff-in-the-blfs-book work with gstreamer-1.0.7? " 

Short answer, no - they're effectively different libraries.

Longer answer, maybe - it depends on the package. The two versions
aren't compatible, but the differences are small enough that some
packages took the approach of supporting both while transitioning from
0.10 to 1.0 APIs. Those that do, usually provide some kind of configure
option, e.g --with-gst=1.0 or something like that.

Simon.




More information about the blfs-support mailing list