[blfs-support] Firefox-21.0 and python-2.6

Ken Moffat zarniwhoop at ntlworld.com
Tue May 28 03:32:47 PDT 2013


On Tue, May 28, 2013 at 08:14:43PM +1200, Simon Geard wrote:
> On Mon, 2013-05-27 at 18:41 -0300, Fernando wrote:
> > Now, python 2.6 is not enough:
> > 
> > Creating Python environment
> > Python 2.7 or greater (but not Python 3) is required to build. You are
> > running Python 2.6.
> > *** Fix above errors and then restart with               "make -f
> > client.mk build"
> > 
> > I think Ken does not recommend upgrading python.
> > 
> > Please, anyone knows how safe or how to upgrade to or install side by
> > side python-2.7?
> 
> It can always be installed to another directory... /opt/python27 or
> something. But I don't know of a good reason not to upgrade it - the
> only catch is that modules are tied to a version, and so any modules
> built against 2.6 would need to be re-installed. But then, you'd need to
> do that with a parallel install anyway.
> 
> Simon.
> 
 Yes, the need to update the modules was the problem - should be
straightforward iff everything that got installed was logged.  I
think my builds are probably doing that now, but at the cost of a
significant overhead in working out what was already installed.

 For some reason I'm still not seeing any of Fernando's posts.
Anybody else missing them ?

ĸen
-- 
das eine Mal als Tragödie, das andere Mal als Farce



More information about the blfs-support mailing list