[blfs-support] libebml download and others

Fernando de Oliveira famobr at yahoo.com.br
Wed Mar 5 08:38:18 PST 2014


Em 04-03-2014 23:25, me at pc-networking-services.com escreveu:
> Hello,
> 
> On the VLC page, under Optional mux/demux plugins there is a dependancy
> for libebml.  If you download the source code from the provided link it
> does not compile.  You need to get it from the git hub:
> 
> https://github.com/Matroska-Org/libebml.git
> 
> 
> Also it may well pay to take a look at the sid-play libs as I have not
> been able to find a version that will successfully compile.
> 
> This may well save some others a few headaches if they are wanting to
> install either of these libraries.
> 
> Regards,
> 
> Christopher
> 

Thanks Laura, Christopher and Armin.

I had commented out the adresses to libmatroska (requires libebml), both
were off-line, during the update to VLC-2.1.3.

Fixed at revision 12822.

Both compile fine here:

cd make/linux &&
make &&
make prefix=/usr install

About sidplay-libs, I have a patch, but is too big, only now I noticed.
The message will not pass with it. Even xzipped it is 284K. I will
upload it compressed to our repository.

I have no idea why it still runs a little configure, when starting make:

patch -Np1 -i sidiplay-lib....patch &&
autoreconf -fi &&
./configure --prefix=/usr &&
make &&
make install

Perhaps one of you can fix to have better instructions.

-- 
[]s,
Fernando


-- 
[]s,
Fernando



More information about the blfs-support mailing list