[blfs-support] gtk+-3 and python3

Fernando de Oliveira famobr at yahoo.com.br
Thu Nov 12 05:41:24 PST 2015


Em 12-11-2015 09:17, Thomas de Roo escreveu:
>  
> 
> Hello, 
> 
> When I tried to install gtk+-3.18.2, the build failed with this error: 
> 
> /bin/sh: /usr/bin/gdbus-codegen: python3: bad interpreter: No such file
> or directory 
> 
> I changed the first line of /usr/bin/gdbus-codegen from 
> 
> #!python3 
> 
> to 
> 
> #!/usr/bin/python3 
> 
> and that fixed it for me. Is this just my setup? Did I miss something
> installing python3 or glib? 
> 
> Regards, 
> 
> Thomas 

When installing glib, instead of

--with-python=python3

use

--with-python=/usr/bin/python3

I will change the book.

Thanks.

-- 
[]s,
Fernando, aka Sísifo


More information about the blfs-support mailing list