[blfs-support] Problem with libdrm-2.4.66

Thanos Baloukas baloukasthan at sch.gr
Fri May 13 15:38:58 PDT 2016


On 14/05/2016 01:20 πμ, José Carlos Carrión Plaza wrote:
> I've got it!
>
> <my compile root dir>/libdrm-2.4.60# sed -i "/pthread-stubs/d"
> configure.ac  && autoreconf -fiv
> autoreconf: Entering directory `.'
> autoreconf: configure.ac: not using Gettext
> autoreconf: running: aclocal --force -I m4 ${ACLOCAL_FLAGS}
> autoreconf: configure.ac: tracing
> autoreconf: running: libtoolize --copy --force
> libtoolize: putting auxiliary files in AC_CONFIG_AUX_DIR, 'build-aux'.
> libtoolize: copying file 'build-aux/ltmain.sh'
> libtoolize: putting macros in AC_CONFIG_MACRO_DIRS, 'm4'.
> libtoolize: copying file 'm4/libtool.m4'
> libtoolize: copying file 'm4/ltoptions.m4'
> libtoolize: copying file 'm4/ltsugar.m4'
> libtoolize: copying file 'm4/ltversion.m4'
> libtoolize: copying file 'm4/lt~obsolete.m4'
> autoreconf: running: /usr/bin/autoconf --force
> autoreconf: running: /usr/bin/autoheader --force
> autoreconf: running: automake --add-missing --copy --force-missing
> configure.ac:38: installing 'build-aux/compile'
> configure.ac:32: installing 'build-aux/missing'
> Makefile.am: installing 'build-aux/depcomp'
> autoreconf: Leaving directory `.'
> <my compile root dir>/libdrm-2.4.60#
>
> VS.:
>
> <my compile root dir>/libdrm-2.4.61# sed -i "/pthread-stubs/d"
> configure.ac  && autoreconf -fiv
> autoreconf: Entering directory `.'
> autoreconf: configure.ac: not using Gettext
> autoreconf: running: aclocal --force -I m4 ${ACLOCAL_FLAGS}
> configure.ac:33: error: must install xorg-macros 1.12 or later before
> running autoconf/autogen
> configure.ac:33: the top level
> autom4te: /usr/bin/m4 failed with exit status: 1
> aclocal: error: echo failed with exit status: 1
> autoreconf: aclocal failed with exit status: 1
> <my compile root dir>/libdrm-2.4.61#
>
Please do not top post. It seems odd that the libdrm version
caused that.

>> I don't know if I've understand you:
>>
>> # ACLOCAL=$(aclocal -I /usr/X11R7.7/share/aclocal)

The blfs-book-7.9 on Introduction to Xorg-7.7 has
ACLOCAL='aclocal -I $XORG_PREFIX/share/aclocal'
(single quotes, not backticks), and not
ACLOCAL=$(aclocal -I $XORG_PREFIX/share/aclocal)
If you have it like that in /etc/profile.d/xorg.sh
I suggest to fix it and retry with libdrm-2.4.66

>> # autoreconf -fiv
>> autoreconf: Entering directory `.'
>> autoreconf: configure.ac: not using Gettext
>> autoreconf: running: aclocal --force -I m4 ${ACLOCAL_FLAGS}
>> configure.ac:33: error: must install xorg-macros 1.12 or later before
>> running autoconf/autogen
>> configure.ac:33: the top level
>> autom4te: /usr/bin/m4 failed with exit status: 1
>> aclocal: error: echo failed with exit status: 1
>> autoreconf: aclocal failed with exit status: 1
>>
>> Thanks for your help.
>>
>> I'm goind to probe with an earlier version of libdrm...
>>
>> Regards.
>>
>> J.C.
>>
>> El , Thanos Baloukas escribió:
>>
>>     On 13/05/2016 11:52 μμ, José Carlos Carrión Plaza wrote:
>>
>>         No. aclocal --print-ac-dir outputs only /usr/share/aclocal
>>         Where did I do a mistake?
>>
>>     My mistake. I should have wrote to check if  ACLOCAL is set to
>>     'aclocal -I $XORG_PREFIX/share/aclocal'
>>
>>     -- Thanos
>>
>
>


-- 
Thanos


More information about the blfs-support mailing list