Ncurses-5.5 install error...

David Fix g4ta4az02 at sneakemail.com
Mon Dec 12 12:29:40 PST 2005


Hey there.  :)  Going through CLFS-SVN-20051210-x86_64-Pure64, I ran into a
problem at 6.16, Ncurses-5.5...  I ran make install, and everything went
fine up until this point:

---
THIS_CC="x86_64-pc-linux-gnu-gcc -m64" \
THAT_CC="gcc" \
sh ./run_tic.sh
** Building terminfo database, please wait...
Running tic to install /tools/share/terminfo ...

        You may see messages regarding extended capabilities, e.g., AX.
        These are extended terminal capabilities which are compiled
        using
                tic -x
        If you have ncurses 4.2 applications, you should read the INSTALL
        document, and install the terminfo without the -x option.

tic: symbol lookup error: tic: undefined symbol: _nc_check_termtype2
? tic could not build /tools/share/terminfo
make[1]: *** [install.data] Error 1
make[1]: Leaving directory `/mnt/lfs/sources/ncurses-5.5/misc'
make: *** [install] Error 2
---

I found the following in google, but I'm not familiar enough with what he's
talking about to make the changes myself:
http://lists.gnu.org/archive/html/bug-ncurses/2005-08/msg00022.html

Anyone a bit more tech-savvy mind helping me out with this one?  :)

	Dave




More information about the cross-lfs mailing list