bison section 10

Justin justinwhelan at tiscali.co.uk
Tue Dec 27 09:37:54 PST 2005


hi,

I am getting a strange error when compiling bison in section 10. In 
calc++ I get

./calc++-scanner.ll: cstdlib: No such file or directory.

this is attempting to compile using g++. I looked a bit further and 
found when i run ./configure towards the end it shows

checking whether g++ creates executables that work.... no

I suspect this maybe at the heart of things, so I created a dummy scripts

/*#include <stdio.h>

int main()
{
  printf("Hello World!\n");
  return(0);
}

*/I then compiled this with

g++ ${BUILD64} dummy.cpp

and ran

./a.out

everything seemed ok and it outputted "Hello World!" without problems, 
so I cannot understand why bison is declaring that g++ cannot make 
working executables. I also done a search for cstdlib and found it in 3 
locations (usr, cross-tools and tools) which is where i would expect to 
find them.

Is this anything anyone can identify or is it just that I may have 
messed up somewhere? I have tried re-installing gcc but the problem 
persists.

Thanks in advance for any help that you may be able to offer,

Justin Whelan



More information about the cross-lfs mailing list