glibc compile error for sparc32

Frederic Arpin clfs at drazil.cjb.net
Fri Nov 11 08:29:31 PST 2005


Hi, i'm trying to compile Glibc-20051024

(http://www.linuxfromscratch.org/clfs/view/cross-lfs/sparc/cross-tools/glibc.html) 
for the sparc32 arch and the compile fails with the following error:

gawk -f ../scripts/gen-as-const.awk ../nptl/sysdeps/sparc/tcb-offsets.sym \
| sparc-unknown-linux-gnu-gcc -S -o 
/mnt/lfs/sources/glibc-build/tcb-offsets.hT3 -std=gnu99 -O2 -Wall 
-Winline -Wstrict-prototypes -Wwrite-strings -g      -I../include -I. 
-I/mnt/lfs/sources/glibc-build/csu -I.. -I../libio -I../nptl 
-I/mnt/lfs/sources/glibc-build -I../sysdeps/sparc/sparc32/elf 
-I../libidn/sysdeps/unix -I../nptl/sysdeps/unix/sysv/linux/sparc/sparc32 
-I../nptl/sysdeps/unix/sysv/linux/sparc 
-I../nptl/sysdeps/unix/sysv/linux -I../nptl/sysdeps/pthread 
-I../sysdeps/pthread -I../nptl/sysdeps/unix/sysv -I../nptl/sysdeps/unix 
-I../nptl/sysdeps/sparc/sparc32 -I../nptl/sysdeps/sparc 
-I../nptl/sysdeps/generic -I../sysdeps/unix/sysv/linux/sparc/sparc32 
-I../sysdeps/unix/sysv/linux/sparc -I../sysdeps/unix/sysv/linux 
-I../sysdeps/gnu -I../sysdeps/unix/common -I../sysdeps/unix/mman 
-I../sysdeps/unix/inet -I../sysdeps/unix/sysv -I../sysdeps/unix/sparc 
-I../sysdeps/unix -I../sysdeps/posix -I../sysdeps/sparc/sparc32/fpu 
-I../sysdeps/sparc/sparc32 -I../sysdeps/wordsize-32 
-I../sysdeps/ieee754/flt-32 -I../sysdeps/ieee754/dbl-64 
-I../sysdeps/sparc/sparc32/soft-fp -I../sysdeps/sparc/fpu 
-I../sysdeps/sparc -I../sysdeps/ieee754 -I../sysdeps/generic/elf 
-I../sysdeps/generic -nostdinc -isystem 
/home/lfs/cross-tools/bin/../lib/gcc/sparc-unknown-linux-gnu/4.0.2/include 
-isystem /tools/include -D_LIBC_REENTRANT -D_LIBC_REENTRANT -include 
../include/libc-symbols.h       -DHAVE_INITFINI -x c - \
       -MD -MP -MF /mnt/lfs/sources/glibc-build/tcb-offsets.h.dT -MT 
'/mnt/lfs/sources/glibc-build/tcb-offsets.h.d 
/mnt/lfs/sources/glibc-build/tcb-offsets.h'
In file included from ../nptl/descr.h:30,
                from ../nptl/sysdeps/sparc/tls.h:70,
                from ../include/tls.h:6,
                from ../sysdeps/unix/sysv/linux/sparc/sparc32/sysdep.h:28,
                from <stdin>:1:
../nptl/sysdeps/unix/sysv/linux/sparc/lowlevellock.h:95:2: error: #error 
SPARC < v9 does not support compare and swap which is essential for 
futex based locking


Here's my setup:

- clfs book = CLFS-SVN-20051110
- host = Linux 2.6.13-gentoo-r5 #1 Sat Nov 5 08:35:40 EST 2005 i686 AMD 
Duron(tm) Processor AuthenticAMD GNU/Linux (Gentoo 2005.1)
- package = Glibc-20051024 (Section 5.7) 
http://www.linuxfromscratch.org/clfs/view/cross-lfs/sparc/cross-tools/glibc.html
- target = sparc32 (Javastation-1, Mr.Coffee)

I've tried with gcc 3.3.6 and gcc 4, same error.

Same thing on Ubuntu 5.10.

In section 1.3:

Sparc v8 and earlier

   Sparc v8 and earlier processors are not supported by NPTL. Sparc v9
   are supported by the Sparc 64 build instructions which utilize NPTL.
   If you have an UltraSparc processor, you have a Sparc v9 which is 64
   Bit.

How is it possible to disable NPTL ? Or does it mean that it is not 
possible to build lfs on sparc32 arch ?

Thanks.

Frederic Arpin






More information about the cross-lfs mailing list