CLFS 7.5: Inetutils-1.4.2 Build error?

Puvvada, Vijay B. VIJAY.B.PUVVADA at saic.com
Mon Nov 21 06:08:23 PST 2005


This is what I got from the compile...

lfs:~$ powerpc-unknown-linux-gnu-gcc -v foo.c 
Using built-in specs.
Target: powerpc-unknown-linux-gnu
Configured with: ../gcc-4.0.2/configure --prefix=/cross-tools
--target=powerpc-unknown-linux-gnu --host=i386-redhat-linux-gnu
--disable-multilib --with-local-prefix=/tools --disable-nls
--enable-shared --enable-languages=c,c++ --enable-__cxa_atexit
--enable-c99 --enable-long-long --enable-threads=posix
Thread model: posix
gcc version 4.0.2
 
/data/lfs_cdk/cross-tools/bin/../libexec/gcc/powerpc-unknown-linux-gnu/4.0.2
/cc1 -quiet -v -iprefix
/data/lfs_cdk/cross-tools/bin/../lib/gcc/powerpc-unknown-linux-gnu/4.0.2/
-D__unix__ -D__gnu_linux__ -D__linux__ -Dunix -D__unix -Dlinux -D__linux
-Asystem=linux -Asystem=unix -Asystem=posix foo.c -quiet -dumpbase foo.c
-auxbase foo -version -o /tmp/ccRReKXj.s
ignoring nonexistent directory
"/data/lfs_cdk/cross-tools/bin/../lib/gcc/powerpc-unknown-linux-gnu/4.0.2/..
/../../../powerpc-unknown-linux-gnu/include"
ignoring duplicate directory
"/cross-tools/lib/gcc/powerpc-unknown-linux-gnu/4.0.2/include"
ignoring nonexistent directory
"/cross-tools/lib/gcc/powerpc-unknown-linux-gnu/4.0.2/../../../../powerpc-un
known-linux-gnu/include"
#include "..." search starts here:
#include <...> search starts here:
 
/data/lfs_cdk/cross-tools/bin/../lib/gcc/powerpc-unknown-linux-gnu/4.0.2/inc
lude
 /tools/include
End of search list.
GNU C version 4.0.2 (powerpc-unknown-linux-gnu)
        compiled by GNU C version 4.0.1 20050727 (Red Hat 4.0.1-5).
GGC heuristics: --param ggc-min-expand=99 --param
ggc-min-heapsize=129472
foo.c:1:16: error: ...: No such file or directory
foo.c:2:15: error: ...: No such file or directory



Vij


On Sun, 2005-11-20 at 23:52 -0500, Ryan Oliver wrote:


On Sun, 2005-11-20 at 19:35 -0500, Puvvada, Vijay B. wrote: 
> Hello All, 
> 
> I am trying to build a linux-from-scratch for a Cerf-Cube 405EP that I 
> have lying around so that I can learn how to build a full distribution. 
> 
> My host environment is a Redhat Fedora Core 4 distribution on a dell 
> laptop (x86) and my target is the cerfcube 405ep (ppc).  As such, I'm 
> not using the live cd. 
> 
> I am following the online version of the CLFS book and so 
> far I have successfully built the cross-tools and temporary tools. 
> 
> I started down chapter 7 (If you're going to boot) and I came to a problem

> when I tried to build inetutils. 
> 
> After patching and so forth, I issued the following configure command.. 
> 
> ./configure --prefix=/usr --libexecdir=/usr/sbin \ 
>     --host=${LFS_TARGET} --sysconfdir=/etc --disable-logger \ 
>     --disable-syslogd --disable-whois --disable-servers 
> 
> It seemed to work. 
> 
> When I tried to do the make, it's trying to use headers, etc. from my host

> setup rather than the actual target setup. 
> 
> Here is a small excerpt of the errors... 
> /usr/include/ncurses/curses.h:1211: error: syntax error before 'trace' 
> /usr/include/ncurses/curses.h:1211: warning: data definition has no type
or 
> storage class

This should not happen, we restrict cpp's include search paths when 
building the cross-gcc in section 5.8.1 with the following commands

--------------8<------------------------- 
Now we will change gcc's search path to look into /tools only: 

cp gcc/Makefile.in{,.orig} 
sed "s@\(^CROSS_SYSTEM_HEADER_DIR =\).*@\1 /tools/include at g" \ 
 gcc/Makefile.in.orig > gcc/Makefile.in 
--------------8<-------------------------


> 
> It almost seems like I would need to tell the make system to change its 
> include path etc. 
> Is it possible I might have missed something in terms of environment?

Possible you may have missed the above step when building the 
cross-compiler...

Could you compile a dummy program with the cross compiler, 
(eg: ppc-unknown-linux-gnu-gcc -v foo.c ) and paste the output into a 
mail 

The section we want is 

#include "..." search starts here: 
#include <...> search starts here: 
  ... 
End of search list.

Best Regards 
Ryan






More information about the cross-lfs mailing list