[BCLFS] multilib pango (32-bit)

Ken Moffat zarniwhoop at ntlworld.com
Tue Nov 22 11:19:39 PST 2005


  I'm trying to build a 32-bit firefox on x86_64, to try using a 32-bit 
plugin (realplayer) - that needs the "gang of 4" of glib-2, pango, atk, 
gtk+-2.  I'm now using slightly old versions of these (revised my basic 
desktop packages before gnome-2.12 was released).

  Oh, and for my own sanity if any of these libs have to be upgraded for 
vulnerabilities, I'm building the 32-bit version, and then the 64-bit.
I've also installed the 32-bit pkg-config as /usr/bin/pkg-config-32, 
although it doesn't seem to make any difference.

  Glib-2 was ok once I passed --host=i686-pc-linu-gnu 
--build=i696-pc-linux-gnu.

  Pango-1.8.1 is a different story.  The big problem seems to be libtool 
- it finds the 64-bit .la files from glib-2, and evaluates these to 
/usr/lib64/libgobject-2.0.so (and perhaps others) during the link.

  I'm configuring with -x-libraries=/usr/X11R6/lib (stops lib64 appearing 
in the Makefile) and building with (watch for line wrap) 
FREETYPE_LIBS='/usr/lib/libfontconfig.so /usr/lib/libexpat.so
/usr/lib/libfreetype.so' which stops the 64-bit versions being pulled in 
from the opentype subdirectory.

  As far as I can see, overriding GLIB_LIBS won't help, it becomes 
'-lgobject-2.0 ...' in configure so it doesn't specify where the 
libraries are to be linked from.  I can't seem to find a way of 
specifying which libgobject-2.0.la should be used, and it seems to 
default to the 64-bit version in /usr/lib64.

  Tried --build and --host like glib-2, but it doesn't solve this 
problem.  Tried updating ltmain.sh from /usr/share/libtool, but no 
better.  There isn't an ltconfig.

  I'm out of ideas.  Has anybody built pango (32-bit) on a recent 
multilib ?  If so, which version, and what needed to be done 
differently ?

Ken
-- 
  das eine Mal als Tragödie, das andere Mal als Farce


More information about the cross-lfs mailing list