Error compiling autoconf in Chapter 10

michi_w2001 at yahoo.de michi_w2001 at yahoo.de
Mon Apr 3 14:46:18 PDT 2006


> > Can't load
> > '/usr/lib64/perl5/5.8.8/x86_64-linux-ld/auto/File/Glob/Glob.so' for
> > module
> > File::Glob:
> > /usr/lib64/perl5/5.8.8/x86_64-linux-ld/auto/File/Glob/Glob.so:
> > wrong ELF class: ELFCLASS64
> > at /usr/lib64/perl5/5.8.8/x86_64-linux-ld/XSLoader.pm line 70.
>
>  I'm not an expert in multilib, (actually, these days I'm not an
> expert in much at all), but I'll hazard a guess that you've built a
> 32-bit perl.  Not sure quite what can do that, but I'll guess that
> perhaps you missed the configure_multilib patch in s10.34 (the
> temporary perl is built as 32-bit, the final perl as 64-bit).
>
>  Normally, I'd tell you to use 'file' on Glob.so, but if you don't
> have that I'll hazard a guess that 'ldd' will show it linking to
> /lib/libc.so.6.
>
>  Alternatively, and from what the message actually says, maybe you
> somehow tried to build autoconf with $BUILD32 ?
>
> Ken

Thank you for your quick reply!

This is my configure for perl:
./configure.gnu --prefix=/usr -Dpager="/bin/less -isR"    
-Dlibpth="/usr/local/lib64 /lib64 /usr/lib64"    -Dcc="gcc ${BUILD64}" 
(I tried the interactive configure script aswell, same result)

My configure for autoconf:
CC="gcc ${BUILD64}" ./configure --prefix=/usr


I ran file and ldd from the host system:

/mnt/lfs/usr/lib64/perl5/5.8.8/x86_64-linux-ld/auto/File/Glob/Glob.so: 
ELF 64-bit LSB shared object, AMD x86-64, version 1 (SYSV), not 
stripped

ldd /mnt/lfs/usr/lib64/perl5/5.8.8/x86_64-linux-ld/auto/File/Glob/Glob.
so
        libc.so.6 => /lib/libc.so.6 (0x00002af5f9164000)
        /lib64/ld-linux-x86-64.so.2 (0x0000555555554000)

I don't know what this output means but perhaps you can help me

	

	
		
___________________________________________________________ 
Telefonate ohne weitere Kosten vom PC zum PC: http://messenger.yahoo.de



More information about the cross-lfs mailing list