Error compiling autoconf in Chapter 10

Ken Moffat ken at linuxfromscratch.org
Mon Apr 3 15:16:57 PDT 2006


On Mon, 3 Apr 2006, michi_w2001 at yahoo.de wrote:

> This is my configure for perl:
> ./configure.gnu --prefix=/usr -Dpager="/bin/less -isR"    
> -Dlibpth="/usr/local/lib64 /lib64 /usr/lib64"    -Dcc="gcc ${BUILD64}" 
> (I tried the interactive configure script aswell, same result)
> 
> My configure for autoconf:
> CC="gcc ${BUILD64}" ./configure --prefix=/usr
> 
> 
> I ran file and ldd from the host system:
> 
> /mnt/lfs/usr/lib64/perl5/5.8.8/x86_64-linux-ld/auto/File/Glob/Glob.so: 
> ELF 64-bit LSB shared object, AMD x86-64, version 1 (SYSV), not 
> stripped
>
 Well, that part looks correct
 
> ldd /mnt/lfs/usr/lib64/perl5/5.8.8/x86_64-linux-ld/auto/File/Glob/Glob.
> so
>         libc.so.6 => /lib/libc.so.6 (0x00002af5f9164000)
>         /lib64/ld-linux-x86-64.so.2 (0x0000555555554000)
> 
> I don't know what this output means but perhaps you can help me
> 

 But that part shows it is using the 64-bit ld-linux with the 32-bit 
libc in/lib.  Which is the problem.

 Are you sure you applied the perl Configure_multilib patch to a freshly 
extracted perl tarball, and echoed the installstyle onto the end of 
hints/linux.sh ?   

Ken
-- 
das eine Mal als Tragödie, das andere Mal als Farce


More information about the cross-lfs mailing list