compiling xorg 7.0.0 on multilib

Ken Moffat ken at linuxfromscratch.org
Sun Apr 23 13:34:18 PDT 2006


On Sun, Apr 23, 2006 at 06:49:01PM +0200, michi_w2001 at yahoo.de wrote:
> Hi,
> 
> I don't know if this is the right place to ask, but I tried to build 
> modular xorg on multilib. Everything appears to install fine.
> I installed the ati and vesa driver packages.
> 
> Then I run "X -configure" (which works aswell), but when I run "X 
> -config xorg.conf.new" I get the following error:
> 
> FATAL: Module radeon not found.
> [drm] failed to load kernel module "radeon"
> (EE) RADEON(0): [dri] DRIScreenInit failed.  Disabling DRI.

 Do you have radeon_drv.so in ${XROOT}/lib64/modules ?
If not, perhaps you have it in lib ?  I'm not up to speed with
modular Xorg, at the moment I'm on 6.9 which uses host.def to
specify where things go, but perhaps pass --libdir to configure.

 As to the rest of it, if it still segfaults when it can find the
radeon driver, I suspect a compiler error (based on my experience
with ppc).  But, building the latest 4.1 gcc snapshot and using
that to rebuild the multitude of packages in modular X is not
something to lightly suggest :-(

Ken
-- 
das eine Mal als Tragödie, das andere Mal als Farce



More information about the cross-lfs mailing list