compiling xorg 7.0.0 on multilib

Ken Moffat ken at linuxfromscratch.org
Wed Apr 26 15:01:14 PDT 2006


On Wed, Apr 26, 2006 at 04:32:18PM -0300, Michael Wiederhold wrote:
> >  Are you using an unpatched gcc-4.1.0 ?
> 
> 
> I'm using gcc 4.0.3 with all the patches from the
> x86-64-multilib book
> 
> Now I removed all the "load" commands from xorg.conf
> and I only get the Backtraces and "Caught Signal 11.
> Server aborting". The point is: I still get an error. 
> 
> I was planning to rebuild CLFS with gcc4.1.0 and maybe
> I should just see if it works then?

 No, I was wondering if you were using the book from the beginning
of last week - gcc-4.1.0 seems to be under control with the two PR
patches, but without them it can silently miscompile in all sorts of
places (e.g. mount from util-linux in the boot option, but ok in
chroot - when I first saw "only root can do that" I thought my
scripts were doing something wrong, and reverted to the tried and
trusted chroot version of the file).

 Your problem is obviously something else, I very much doubt that
upgrading glibc, headers, gcc is going to help until you can
discover what is going wrong in X.

Ken
-- 
das eine Mal als Tragödie, das andere Mal als Farce



More information about the cross-lfs mailing list