ppc64, was Re: r1123

Ken Moffat ken at linuxfromscratch.org
Thu Feb 2 08:36:13 PST 2006


On Wed, 1 Feb 2006, Jeremy Huntwork wrote:

> Haven't gotten that far yet. I'm making this up as I go. :P Will be testing 
> it in the next day or so, though. Hopefully.

  Issues I'm aware of in ppc64 (from my notes of 6 or 8 weeks ago) -

1. Test failures

Binutils has 18 test failures on ld visibility
Glibc 32-bit test failures all over the shop, similar to x86_64 32-bit
Gcc - I seem to have had a lot of g++ test failures
(I don't think these are necessarily important, but I haven't 
managed to build very much on that system, so there might be real 
problems lurking in g++).

2. Building

Mktemp:

config.guess and config.sub need to be updated - either from 
savannah.gnu, or more easily from /usr/share/automake-1.9/ if that has 
already been installed.

Powerpc-Utils:

  Use the -2 version of the patch (I've just checked it in), then 'make 
EXTRACFLAGS="${BUILD32}" make nvsetenv nvsetvol' - there is an issue 
with this : if you run nvsetenv with no args, the console gets screwed 
up, so it's possible that this might be implicated in the yaboot runtime 
problem.

Yaboot:

  uses 'gcc -Os' in its Makefile to produce code which is 
incompatible with powerpc:common64.  Note that fedora defaults to -m32 
for powerpc64 gcc, so they don't have this issue.  If you pass CC="gcc 
-m32" that will be overwritten by CC := $(CROSS)gcc in the Makefile 
which just drops it back to "gcc". I used the following sed :
sed -i "s/\(-print-libgcc-file-name\)/${BUILD32} \1/" Makefile

  I also tried a 64bit patch from fedora (attached as .bz2, it's big) - 
putting all the bits together (also tried other fedora patches, but I don't 
think they are relevant), I got yaboot to compile.  Don't forget the 
ofpath sata patch for powermacs.  The good news was that ybin updated 
the OF, and that I could still boot from OSX and from CD (64-bit kernel, 
obviously - I used ubuntu because debian had issues with my recent 
hardware).  The bad news was that the second-stage bootloader for linux 
didn't work, so I had to boot from my CD and rerun ybin from ubuntu.

BCLFS:

  And don't get me started on the cdrecord and desktop issues with 
ppc64... :->

Ken
-- 
  das eine Mal als Tragödie, das andere Mal als Farce
-------------- next part --------------
A non-text attachment was scrubbed...
Name: yaboot-1.3.8-ppc64-initrd.patch.bz2
Type: application/octet-stream
Size: 3966 bytes
Desc: 
URL: <http://lists.linuxfromscratch.org/pipermail/cross-lfs/attachments/20060202/ec22b2b4/attachment.obj>


More information about the cross-lfs mailing list