/bin/sh: -c: line 0: syntax error near unexpected token `('

Chris Staub chris at beaker67.com
Mon Feb 6 09:52:44 PST 2006


John Gay wrote:
> I can usually puzzle my way through most errors, but this one stumps me. I'm 
> trying to build a 2.6.16-rc2 kernel from within the pure-64 build on my Dual 
> Opteron. I run the usual make mrproper, make menuconfig fine, but when I then 
> run make, it errors immediately with:
> 
> Seems the first error is some sort of shell-script error, but since the 
> Makefile suppresses the directory entrys I don't know where to look?
> 
> I've tried various config setting, including make defconfig, for all default 
> settings and make allnoconfig for minimal config, as well as make oldconfig 
> from my current running 2.6.12.5 32 bit system updated as best as I know how.
> 
> If I can't get a 2.6.16 kernel built to update the udev rules in this first 64 
> bit build, I'll have to wait until the CLFS book is updated to this level.
> 
> Cheers,
> 
> 	John Gay

That's a typical error when you're missing /dev/null. Try restarting udev.



More information about the cross-lfs mailing list