/bin/sh: -c: line 0: syntax error near unexpected token `('

John Gay johngay at eircom.net
Mon Feb 6 07:14:32 PST 2006


On Monday 06 February 2006 18:55, martin ward wrote:
> Chris Staub wrote:
> > John Gay wrote:
> >> I can usually puzzle my way through most errors, but this one stumps
> >> me. I'm trying to build a 2.6.16-rc2 kernel from within the pure-64
> >> build on my Dual Opteron. I run the usual make mrproper, make
> >> menuconfig fine, but when I then run make, it errors immediately with:
> >>
> >> Seems the first error is some sort of shell-script error, but since
> >> the Makefile suppresses the directory entrys I don't know where to look?
> >>
> >> I've tried various config setting, including make defconfig, for all
> >> default settings and make allnoconfig for minimal config, as well as
> >> make oldconfig from my current running 2.6.12.5 32 bit system updated
> >> as best as I know how.
> >>
> >> If I can't get a 2.6.16 kernel built to update the udev rules in this
> >> first 64 bit build, I'll have to wait until the CLFS book is updated
> >> to this level.
> >>
> >> Cheers,
> >>
> >>     John Gay
> >
> > That's a typical error when you're missing /dev/null. Try restarting
> > udev.
>
> Funny you should mention that did a crosslfs the other day, with the
> 2.6.16-rc2 kernel, and got exactly the same error, couldn't fathom it
> either so went back to 2.6.15.1 which worked, applied gkh patches and
> the new udev works fine
>
How bizarre! When I run make config, with any config type, /dev/null changes 
to a regular file, and I have to run /etc/rc.d/init/udev start again, then 
the kernel compiles fine???

Someone with more smarts than me will have to figure that one out.

Cheers,

	John Gay



More information about the cross-lfs mailing list