/bin/sh: -c: line 0: syntax error near unexpected token `('

John Gay johngay at eircom.net
Mon Feb 6 09:05:06 PST 2006


On Monday 06 February 2006 22:23, Ken Moffat wrote:
> On Mon, 6 Feb 2006, John Gay wrote:
> > How bizarre! When I run make config, with any config type, /dev/null
> > changes to a regular file, and I have to run /etc/rc.d/init/udev start
> > again, then the kernel compiles fine???
> >
> > Someone with more smarts than me will have to figure that one out.
> >
> > Cheers,
> >
> > 	John Gay
>
>   This is a problem with both rc1 and rc2, for people who build as root
> (yes, I realise that in chroot there is no realistic alternative).
> The attachment is from Friday's lkml.
>
Thanks for the info. Since I've got the base system built and running, I 
actually boot into it to build. I just haven't added any other users to it, 
since I don't plan to keep it around that long.

I've now got it running with the 2.6.16-rc2 kernel, and I tried just adding 
your udev-cross, but it's still got all the old hotplug stuff polluting the 
boot-up process. Think I'll just wipe it and start again. I should be able to 
wipe everything but /cross-tools and start from that point rather than going 
back to the beginning. Now that I know about the /dev/null problem, I can 
work around it until the kernel gets updated again.

Just to be sure I'm thinking right, I'll install the bootscripts, and your 
udev scripts, but leave out the hotplug stuff next time?

Looks like I'll be busy again tomorrow (-; (Sorry Cingular Wireless X-D )

Cheers,

	John Gay



More information about the cross-lfs mailing list