MIPS multilib cross-compiler build fails

Michael J. Hammel cross-lfs at graphics-muse.org
Wed Jan 4 12:52:38 PST 2006


On Wed, 2006-01-04 at 15:05 -0500, Joe Ciccone wrote:
> One question, are you deleting the build and source dirs before building
> the package again? 

No the directories are in tact for the first pass of the builds.
However, I haven't gotten to any rebuilding yet - the problem arises
after I do:

libcheaders
binutils
gcc - first pass
glibc 32bit

At the glibc 32 bit build I run into the error:
../sysdeps/generic/strtol.c:101: error: '__EI___strtol_internal' aliased
to undefined symbol '__GI___strtol_internal'
make[4]: *** [/mnt/lfs/sources/bld/glibc-20051107/stdlib/strtol.os]
Error 1

> It seems to be a common mistake amoungst people and
> when cross-compiling it never errors in the same place twice, hard to
> trace back.

This error actually is very reproducable.  I've tried replacing the
toolchain on my host system with versions matching the CLFS build for
MIPS Multilib too.  Same problem.
-- 
Michael J. Hammel           |
The Graphics Muse           |  Why do five out of four people have trouble 
mjhammel at graphics-muse.org  |  with fractions?
http://www.graphics-muse.com 




More information about the cross-lfs mailing list