Why does shadow need a patch?

Chris Staub chris at beaker67.com
Tue Jan 17 21:12:43 PST 2006


The shadow installation in {C}LFS has a patch to "fix" the issue of pam, 
auditing, and selinux support being enabled by default. Shadow seems to 
compile just fine without the patch if I just add "--without-selinux 
--without-libpam --without-audit" to configure. Is there any reason for 
patching instead of just using switches to the configure command?



More information about the cross-lfs mailing list