MIPs Multilib network boot panics when looking for init

Ken Moffat ken at linuxfromscratch.org
Thu Jan 19 05:06:39 PST 2006


On Wed, 18 Jan 2006, Michael J. Hammel wrote:

> I'm kinda stuck on this one - was hoping someone could point me in the
> right direction.  The boot fails trying to launch an init program.  I've
> tried the defaults (/sbin/init and friends) and also tried init=/tools-
> mips/bin/bash (the fully qualified location for the bash program in the
> temporary tools directory) but they all give me the same error.  It
> seems like the loader isn't finding the libraries it needs.  I tried
> symlinking /lib{,32,64} and /usr/lib{,32,64} to their counterparts
> under /tools-mips, but that didn't change anything.

  I've no experience with MIPS, but as a general principle it's dangerous 
to change /tools to something different.  Just like in vanilla LFS, we 
may hard code it into patches.  So, you should review the patches (and 
seds) in case a reference to /tools is still in there.

  You might be able to use 'readelf -l' from your cross-compiled binutils 
to take a look at the 'Requesting program interpreter:' fields of the 
binaries for the target [this is a guess, but I don't see why it 
shouldn't work :-) ].

Ken
-- 
  das eine Mal als Tragödie, das andere Mal als Farce


More information about the cross-lfs mailing list