MIPs Multilib network boot panics when looking for init

Jim Gifford lfs at jg555.com
Thu Jan 19 07:53:16 PST 2006


Michael J. Hammel wrote:
> I'm kinda stuck on this one - was hoping someone could point me in the
> right direction.  The boot fails trying to launch an init program.  I've
> tried the defaults (/sbin/init and friends) and also tried init=/tools-
> mips/bin/bash (the fully qualified location for the bash program in the
> temporary tools directory) but they all give me the same error.  It
> seems like the loader isn't finding the libraries it needs.  I tried
> symlinking /lib{,32,64} and /usr/lib{,32,64} to their counterparts
> under /tools-mips, but that didn't change anything.
>
> I seem to have everything in place for a NFS based rootfs boot as far as
> CLFS is concerned, but the kernel panics when trying to launch init:
>
> [4294669.328000] IP-Config: Complete:
> [4294669.329000]       device=eth0, addr=172.22.251.219,
> mask=255.255.255.0, gw=255.255.255.255,
> [4294669.333000]      host=172.22.251.219, domain=, nis-domain=(none),
> [4294669.334000]      bootserver=172.22.250.84,
> rootserver=172.22.251.154, rootpath=/mnt/lfs-mips
> [4294669.337000] Looking up port of RPC 100003/2 on 172.22.251.154
> [4294669.339000] Looking up port of RPC 100005/1 on 172.22.251.154
> [4294669.347000] VFS: Mounted root (nfs filesystem) readonly.
> [4294669.348000] Freeing unused kernel memory: 192k freed
> [4294669.358000] Kernel panic - not syncing: No init found.  Try passing
> init= option to kernel.
>
> /sbin/init exists in the mount point:
> mjhammel(tty5)$ ls -l /mnt/lfs-mips/sbin/init
> -rwxr-xr-x  1 root root 44336 Jan 18 16:43 /mnt/lfs-mips/sbin/init
>
> And it appears to be the right kind of file (built with -meb -mabi=64 -
> mtune=sb1 -march=mips64 for a Broadcom Bigsur board:
> mjhammel(tty5)$ file /mnt/lfs-mips/sbin/init
> /mnt/lfs-mips/sbin/init: ELF 64-bit MSB MIPS32 executable, MIPS, version
> 1 (SYSV), for GNU/Linux 2.6.0, dynamically linked (uses shared libs),
> stripped
>
>   
I see something odd here. MIPS32 executable. Now I've seen this problem 
before with my RaQ2, if the filesystem is not exported to what the 
NFSROOT is expected to be with the firmware. In the case of the  RaQ2 it 
was nfsroot. The other time I've seen this issue the nfs server wasn't 
advertising correctly, normally fixed by restarting the nfs server.


-- 
------
jim at linuxfromscratch.org
lfs at jg555.com

LFS User # 2577
Registered Linux User # 299986




More information about the cross-lfs mailing list