Starting again.

John Gay johngay at eircom.net
Mon Mar 6 03:55:07 PST 2006


On Monday 06 March 2006 17:30, Jeremy Utley wrote:
> On 3/6/06, John Gay <johngay at eircom.net> wrote:
> > On Sunday 05 March 2006 19:55, you wrote:
> > > John Gay wrote:
> > > > However, the new system still doesn't setup any modules on bootup.
> > > > The only curious thing is, when I was cross-compiling udev, it didn't
> > > > install udevstart, even though it compiled it, so I copied udevstart
> > > > to /sbin. When I rebuilt udev in ch-10.53 I didn't see it get
> > > > installed either, but it was there, so I didn't think much about it
> > > > till now. ls -l shows that the udevstart in /sbin is the one from the
> > > > cross-compile step, not hte one I built today, though I don't think
> > > > that should matter.
> > >
> > > udevstart is no longer a part of the build. Did you have the uevent
> > > handler in your kernel config. Don't remember the option right off the
> > > top of my head.
> >
> > Just to check, I removed the udevstart that I have copied from the
> > cross-compile stage and tried re-booting again and I get these errors:
> >
> > Populating /dev with device nodes...
> > /etc/rc.d/rcsysinit.d/S10udev: line 70: udevstart: command not found
> > [FAIL] Activating all swap files/partitions...
> > swapon: cannot stat: /dev/hda2: No such file or directory
> >
> > (etc)
> >
> > finishing with the root partition not being detected and the system
> > halts.
> >
> > So obviously, if udevstart is no longer part of the build,
> > then /etc/rc.d/init.d/udev needs fixing. Searching about this, I found an
> > LFS book updated for udev-085 and the build sequence is very much
> > different. An interesting point, though, the last step is to run:
> > /sbin/udevstart
> >
> > But udevstart is not listed in the contents of udev? And yet it is
> > compiled during the make phase, it's just not copied during the install
> > phase?
> >
> > Further googling does not clear this up. Most comments claim the lack of
> > udevstart in udev-085 is a bug and suggest copying it to /sbin manually?
> >
> > Any further clarification is appreciated.
>
> Jim's download he has pointed you to many times contains an updated
> udev start script.  What must happen is a hotplug event must be
> generated manually for any device that was connected and initialized
> before udev gets started.  Jim's udev script starts udev via "udevd
> --daemon", then walks the /sys tree, generating events for every
> device.
>
Thanks. I did download and install these scripts, but for some reason, they 
didn't replace the udev and udev_retry installed by the bootscripts? Copying 
these over by hand fixed the issue, now I need to go back and see why they 
didn't get installed the first time round.

Also, when I built udev-085, I based my build on the udev-076 instructions 
from the CLFS book, but now I see there are update LFS instructions for 
udev-085 that are very different, so I'll look to see what impact that has on 
my build. What I don't understand, though, in the udev-085 instructions, 
after it's all built, is says to run /sbin/udevstart when this is no longer 
installed, as this thread covers.

Thanks again for your clarifications. 

Cheers,

	John Gay



More information about the cross-lfs mailing list