[elinks-users] mime types/mailcap problem in 0.5pre6

Jean-Yves Levesque jyves at nortelnetworks.com
Mon Oct 6 18:19:03 PDT 2003


On Tue, Oct 07, 2003 at 12:58:10AM +0200, Jonas Fonseca wrote:
> Jean-Yves Levesque <jyves at nortelnetworks.com> wrote Mon, Oct 06, 2003:
> > I am trying to view a jpeg image from elinks using 0.5pre6.
> > It always tells me the type is unknown (image/jpeg) even though the
> > type is set correctly. This works fine with 0.4.x. The latest CVS
> > snapshot (Oct. 06) is also showing the same behaviour. Is there
> > something missing ? I have not seen anything on the archive.
> 
> You mention you have used 0.4.x before. It could maybe be a problem with
> the renaming of the mailcap options. Could you maybe grep for your
> mailcap options in ~/.elinks/elinks.conf and feed them back .. also
> maybe try to test it with a new elinks.conf file[0] and see if the
> behaviour is still there?

	I did removed my .elinks directory just to be sure. No change.
	I did try to disable and enable it but did not see any change.

	Still works with the 0.4 branch.
> 
> I did some changes recently so that the mailcap files are only loaded
> when necesary. Iwouldn.t say it is very well tested but it works for me
> so I doubt this can be the cause.

	Maybe but how do we know the mailcap is loaded?
> 
> [0] You can use the recently added -confdir parameter:
>     -confdir <str>        Set config dir to given string.

	Do not see it in pre6, neither in Oct 06 build.

	On another note, the pre6 source does not contain the
	palette.inc file. Had to copy it from the oct 06 build.

	Jean-Yves.
> 
> -- 
> Jonas Fonseca

-- 
Jean-Yves Levesque - Nortel Networks - jyves at nortelnetworks.com
P.O. Box 3511, Station C Ottawa, Canada  K1Y 4H7
-
Ideas expressed belong to the owner and not to the company



More information about the elinks-users mailing list