[elinks-users] Re: ELinks 0.9.1 on Mac OS X 10.3.2

Daniel E. Macks dmacks at netspace.org
Tue Mar 16 09:42:23 PST 2004


Petr Baudis <pasky at ucw.cz> said:
> Dawn Forty-Six <dawn46 at mailandnews.com> told me, that...
>> I've installed elinks-0.9.1 via fink on Mac OS X 10.3.2, and have experienced 
>> odd frame-related 
>> behavior.  Instead of displaying frames in html pages, it displays a 
>> lynx-style "Frame: Top {Middle, 
>> Right, etc.}" menu.
>> 
>> Has anyone else encountered this behavior?
>> 
>> (Changing the program's settings seems to have no effect.)
> 
> Interesting... check that document.html.display_frames is set to 1
> (press 'o' and dive into the options tree). If it is, I have no idea, it
> should work fine everywhere else. And if it isn't, I wonder why did the
> fink people changed the default settings.

This is using elinks configured with --without-gpm --without-lua --wi
thout-guile --without-x and either with or without openssl support,
and no preferences or settings changes. Also happens in 0.4.2
configured the same way. Here's a test case:

example1.html:
  <html>
      <frameset cols="*">   <!-- also 'rows' instead of 'cols'-->
        <frame src="page.html">  <!-- any dinky html file -->
        <frame src="page.html">
      </frameset>
  </html>

page.html:
  <html><body>
  testing
  </body></html>

For me, this renders incorrectly, but renders correctly if the
cols="*" attribute is removed from the <frameset>. If the missing
<body></body> is added around the <frameset></frameset>, it renders
incorrectly even if the cols attribute is removed.

dan, fink person for elinks

-- 
Daniel Macks
dmacks at netspace.org
http://www.netspace.org/~dmacks





More information about the elinks-users mailing list