[elinks-users] Re: In need of people experiencing DNS problems with 0.9.0

Stephen Stocker lpar at par1.net
Wed Mar 31 07:46:30 PST 2004


 
 	Hi,

  I just noticed this from January. I found that turning async_dns off
  (0) made a world of difference for me! I had been seeing a lot of
  "Host not found" messages, so I just hit the link again and it'd work.
  But I noticed this option and tried turning it off the other day.
  Since then it's been great! I haven't tried changing the code in
  dns.c, but will tonight, if it's still the same in the current CVS. I
  didn't even think of it as a problem, since the solution was so
  simple!

  	Take care,
	Steve

  
>    Hello,
> 
>    please, if you are experiencing DNS problems with 0.9.0, we need your
>  help. First, does it fix when you set connection.async_dns to zero?
>  Second, does it help when you have async_dns set to 1 and change line
>  208 of file src/lowlevel/dns.c from
> 
>                          if (r <= 0) goto done;
> 
>  to
> 
>                          if (r < 0) goto done;
> 
>  ?
> 
>    Thanks a lot in advance,
> 
>  --
>  
>                                  Petr "Pasky" Baudis
>  .
>  If a train station is where the train stops, what is a work station? --mj
>  .
>  Stuff: http://pasky.or.cz/
> 



More information about the elinks-users mailing list