[elinks-users] How do I enable the pretty line graphics and colors under gnu/screen [SOLVED]

cga cga2001 at softhome.net
Sat Jan 1 19:44:05 PST 2005


Miciah Dashiel Butler Masters wrote:

>On 20041231 13:59:11, Jonas Fonseca <fonseca at diku.dk> wrote:
>  
>
>>cga <cga2001 at softhome.net> wrote Thu, Dec 30, 2004:
>>    
>>
>>>Jonas Fonseca wrote:
>>>      
>>>
>[...]
>  
>
>>>As I see it elinks does not at present support gnu/screen's virtual
>>>terminals - ie.  "screen", "screen-w", etc.. In other words I would
>>>need to patch elinks to add support  for these terminal types.
>>>
>>>Am I correct in assuming this?
>>>      
>>>
>
>This is entirely wrong. As the document says, you need only configure
>your terminal within ELinks: Go to the Setup menu and select Terminal
>Options. GNU Screen is VT100-compatible, so select 'VT 100 frames'.
>GNU Screen also supports colours just fine, so select '16 colors';
>or if you are running Screen within a terminal emulator that supports
>256 colours and you have compiled both Screen and ELinks to support it,
>choose '256 colors'.
>
Made my day.. night rather.. I first tried it on an older RedHat 7.2 
system where
I happen to run elinks version 0.9.2 and that took care of most of the 
problem.
There were still a few ugly rectangles and the odd line of Ä's but 
framed tables
were quite readable.

I rebooted into Debian sarge and found that with the new 4.x version of 
einks
- or is it some subtle difference in console setups between RH and 
Debian - the
problem is entirely fixed. All documents I have checked display line 
drawings
perfecty. Not to mention that (OT) the various romance languages that I use
and german all displayed faultlessly.  After that (more OT) seeing that 
elinks
does everything I needed I spent the entire night reviewing its incredibly
rich set of customizable options - have you ever tried changing keyboard
shortcuts in mozilla/netscape? :-) .. By seven in the morning I was thinking
of sending a personal thank-you email to the developers..! 

>ELinks does not use termcap or terminfo. ELinks uses $TERM, but only to
>distinguish between terminals in its own configuration. If $TERM is set
>to 'screen' when you configure ELinks' terminal settings, ELinks will
>remember to use those settings when $TERM is 'screen'.
>  
>
Therefore elinks only ambitions to support i386 console linux and 'X', 
right  (?)
Can't see how you can port it to the whole wagonload of legacy terminals
otherwise...  

>>I don't really know how screen works but since screen can be run from
>>various terminal emulators with different capabilities I don't know if
>>it makes much sense to have a predefined configuration for the
>>``screen'' terminal. Try to run:
>>
>>	TERM=xterm elinks
>>
>>It should work for you.
>>
>This is a hack and should not be done.
>  
>
Agreed.. I hadn't seen the Terminal Options in the Setup menu, only the 
"Terminals"
setcion in the options manager.

>>>Or is it worse than this..? Would it also be a case of gnu/screen's
>>>terminal definitions not supporting the capabilities that elinks would
>>>need to display line graphics?
>>>      
>>>
>>I just tried the above. Telling elinks to output for xterm when running
>>in screen (on a linux console) gives you most of the desired display
>>capabilities (both colors and line graphics). The linux console has
>>double lined line graphics which doesn't seem to work under this
>>setting, but that is a small price to pay, IMO.
>>    
>>
>
>Do people seriously see the double-lines as a killer feature?
>
Don't you? :-)

No, my problem was that lots of things like the elinks menus and 
management panels
as well as html tables with line drawing frames were barely legible. You 
can check for
yourself by replacing all the line characters by Ä's on a large table 
with numerous cells.
A right mess it gives you and in a different sense a real "killer 
feature" - ie. if it could
not be fixed.. elinks was dead.. at least as far as I was concerned.

>You can always make a custom font...
>
>  
>
Yes, that's probably my next step.. plus one... First I need to figure 
out how console
fonts really work. I like very much the font that I use on the console 
and showcfont
displays the same glyphs in the same slots as when I'm using the 
default.. and  yet
it displays  the expand/collapse characters in the options manager 
differently. With
the default font I get some nice arrow heads - a bit like a '>' - 
greater-than sign but
"filled"..  - showcfont has these arrowheads in 0x10, 0x11, 0x1E, 0x1F.. 
and with my
replacement font I get a "vertical rectangle".  No idea why..

Anyway sorry for the verbose post nd thank you *very* much indeed for 
providing a
timely solution.
cga







More information about the elinks-users mailing list