[elinks-users] elinks 0.10.5 slow at resolving hostnames on Cygwin-X

Miciah Dashiel Butler Masters miciah at myrealbox.com
Sun Sep 4 20:35:46 PDT 2005


On Mon, Sep 05, 2005 at 04:02:49AM +0100, Andrew Preater wrote:
> * Miciah Dashiel Butler Masters <miciah at myrealbox.com> [2005-09-05 01:58]:
> > On Mon, Sep 05, 2005 at 01:27:06AM +0100, Andrew Preater wrote:
> >> I have a problem with elinks under Cygwin-X on Win2000 SP4.  I
> >> didn't find anything about it on the list on in the bugzilla,
> >> so here I am. :)
> >> 
> >> When I load a url, elinks spends a long time looking up the
> >> hostname of the server: it will spend four or five seconds
> >> with the message 'Looking up host' in the status bar.
> >
> > This is reported as bug 691, 'Host lookup is slow', which
> > probably should have its summary improved. There is a proposed
> > work-around.
> 
> Hi,
> 
> Yes - I tried searching the bugzilla, but it didn't come up with
> anything.  I was starting to think there *were* no bugs!

Oh, ELinks has _plenty_ of bugs.

Seriously, are you saying that the search is broken, or were you just
having difficulty because of the poorly-titled report for bug 691?

> > I see the I need to update it, and I will do so promptly.
> > Please try the work-around and report whether it works along
> > with information on your software configuration.
> 
> I've tried it, and it worked perfectly.  No hang when loading a
> url (any protocol).  I pulled elinks from cvs, and made sure I
> had revision 1.126 of dns.c.
> 
> [...]

Thank you for confirming that the work-around works. Now somebody
just needs to backport it so that it will be in the next 0.10 release.

-- 
Miciah Masters <miciah at myrealbox.com> / <mdm0304 at mail.ecu.edu>



More information about the elinks-users mailing list