[elinks-users] Can't compile eLinks Debian (PowerMac; Kernel 2.4.22)

Jonas Fonseca fonseca at diku.dk
Tue Jan 31 07:06:50 PST 2006


Phillip Pi <ant at zimage.com> wrote Tue, Jan 31, 2006:
> OK, I got the patch and tried it, but still failed:

But yay, there is progress! :)

Side note: you don't need to add the whole configure + make log every
time. It was great in the start but onwards something equivalent to the
below will do.

>       [CC]   src/main/timer.o
> In file included from ../.././src/main/timer.h:4,
>                  from timer.c:10:
> ../.././src/util/time.h:44: error: syntax error before 'n'
> make[2]: *** [timer.o] Error 1
> make[2]: Leaving directory `/u00/home/ant/download/elinks-0.11.1/src/main'
> make[1]: *** [all-recursive] Error 1
> make[1]: Leaving directory `/u00/home/ant/download/elinks-0.11.1/src'
> make: *** [all-recursive] Error 1

As Zas replied I think we need to fix util/time.h, although I somehow
doubt it will fix it. It seems we need to include elinks.h always before
system headers.

> Also, I have not tried compiling this under Mac OS X 10.2.8 so I hope
> it can compile there too. I will try that later on like on the weekend
> or whatever.

If you have the time, that will be great. I don't think the new build
system and the other changes since 0.10 has been exercised on Mac OS X.

-- 
Jonas Fonseca



More information about the elinks-users mailing list