[elinks-users] renderer.c:1685: error: 'struct cache_entry' has no member named 'cache_mode' when compiling eLinks v0.11.3 in Debian (PowerPC)

Phillip Pi ant at zimage.com
Sun Jul 1 09:23:08 PDT 2007


On Sun, Jul 01, 2007 at 12:50:00PM +0300, Kalle Olavi Niemitalo wrote:
> Phillip Pi <ant at zimage.com> writes:
> 
> > I don't want to get an account for eLink's bugzilla but I did post the 
> > two config files in a zip file: http://www.savefile.com/files/854658 ...
> 
> Oops, I had seen your name in connection to some earlier bug
> fixes so I thought you already had an account there.

Nah, I just post a lot. :) I seem to get errors with compilations in
every stable releases on something (Mac OS X, Debian PowerPC, or
something oddball OS). ;)


> > I hope that was correct. However, I got errors again: 
> > http://pastebin.ca/598156
> 
> Well I meant you to compile those four lines as a separate file.
> But never mind, config.log already contains similar information.

OK.

 
> > ... Again, config files as a zip file if you 
> > need them: http://www.savefile.com/files/854708 ...
> 
> This config.h does not mention HAVE_SYS_TYPES_H at all.
> It also begins with these lines
> 
> /* config.h.  Generated by configure.  */
> /* config.h.in.  Generated automatically from configure.in by autoheader 2.13.  */
> 
> whereas the previous one (which defined HAVE_SYS_TYPES_H) began:
> 
> /* config.h.  Generated by configure.  */
> /* config.h.in.  Generated from configure.in by autoheader.  */
> 
> It seems something has run autoheader 2.13 in your computer

Actually, it's my friend's box. I ssh to it to use it.


> and it did not handle configure.in entirely right.  I am using
> Autoconf 2.61 here, and when I last tried 2.13, I got errors.
> We should probably change the AC_PREREQ(2.13) in configure.in
> to something more recent, so that old versions of Autoconf would
> refuse to process the file; but of course that won't help with
> the already released ELinks 0.11.3.
> 
> Please delete that source tree and start over from
> elinks-0.11.3.tar.gz (or .bz2).  Then add these lines to the
> beginning of src/util/time.h, above #ifndef EL__UTIL_TIME_H:
> 
> #ifdef HAVE_SYS_TYPES_H
> # warning "HAVE_SYS_TYPES_H defined"
> #else
> # warning "HAVE_SYS_TYPES_H not defined"
> #endif
> #ifdef _SYS_TYPES_H
> # warning "_SYS_TYPES_H defined"
> #else
> # warning "_SYS_TYPES_H not defined"
> #endif
> #ifdef __off_t_defined
> # warning "__off_t_defined defined"
> #endif
> # warning "__off_t_defined not defined"
> #endif
> #ifdef __USE_FILE_OFFSET64
> # warning "__USE_FILE_OFFSET64 defined"
> #endif
> # warning "__USE_FILE_OFFSET64 not defined"
> #endif
> 
> Configure and compile, and post the build log so that I can see
> the resulting warnings.  It will be especially interesting to see
> whether the warnings differ between renderer.c and other files.
> If they become errors rather than warnings, remove -Werror from
> CFLAGS in Makefile.config.

After the compilation, I checked Makefileconfig and didn't see any 
"Werror". I attached Makefile.config as well in the zip file with files: 
http://www.savefile.com/files/855926 ...
-- 
"Trivial hurts, tiny human accidents," said Firenze, as his hooves 
thudded over the mossy floor. "These are of no more significance than 
the scurryings of ants to the wide universe, and are unaffected by 
planetary movements." --Harry Potter book
  /\___/\
 / /\ /\ \     Phillip (Ant) @ http://antfarm.ma.cx (Personal Web Site)
| |o   o| |         Ant's Quality Foraged Links (AQFL): http://aqfl.net
   \ _ /                 E-mail: philpi at earthlink.net or ant at zimage.com
    ( )



More information about the elinks-users mailing list