[elinks-users] FSP in ELinks 0.11.3

Kalle Olavi Niemitalo kon at iki.fi
Sun Apr 27 00:00:46 PDT 2008


Y Giridhar Appaji Nag <giridhar at appaji.net> writes:

> I included this as a patch in the Debian package for the 0.11.3
> series.

The FSP support in ELinks 0.12.GIT has one other patch you should
take note of.

commit e517ef22a9c3abab9bf202a76c8f3b4e44c6a773
Author: Kalle Olavi Niemitalo <kon at iki.fi>
Date:   Tue Mar 6 15:55:08 2007 +0200

    fsp: Try to recover from ABI mismatches caused by _FILE_OFFSET_BITS.

It tries to work around this fsplib bug:

fsplib 0.8 ABI depends on _FILE_OFFSET_BITS
https://sourceforge.net/tracker/index.php?func=detail&aid=1674729&group_id=93841&atid=605738

As far as I can tell, this has not been fixed in the Debian
fsplib 0.9-1 packages.  So, if you enable FSP support, please
make sure that the Debian ELinks packages are built with the
same _FILE_OFFSET_BITS as the Debian fsplib packages.



More information about the elinks-users mailing list