[elinks-users] ELinks 0.12pre5 - Garbled display with UTF-8 I/O enabled.

Kalle Olavi Niemitalo kon at iki.fi
Sat Sep 19 02:12:08 PDT 2009


Chris Jones <cjns1989 at gmail.com> writes:

> For this test, I ran ELinks in the following context:
>
> xterm(235)
>
> $ xterm -fn "-gnu-unifont-medium-r-normal--16-160-75-75-c-80-iso10646-1" \ 
>         -tn "xterm-256color" -u8

I tried with xterm 235 running on Debian, X11 2.4.0 from
xquartz.macosforge.org running on Mac OS 10.5.8, and unifont
1:5.1.20080914-1 from Debian installed on the Mac.

printf "abcdefgh\r\xE7\x89\xB9\xE5\x88\xA5XY\n"
should display two fullwidth CJK characters (U+7279 U+5225)
followed by "XYgh".  However, the CJK characters get drawn
as too narrow, taking up only two and a half character cells
together, instead of four; all of the "d" and part of the "c"
remain visible.  If I then select the line with the mouse,
xterm redraws it in the expected way.

So, there seems to be an incompatibility between xterm and this
font, before ELinks is even started.  I don't think it'll be
useful to look for a bug in ELinks until that has been fixed.



More information about the elinks-users mailing list