[elinks-users] ELinks 0.12pre5 - Garbled display with UTF-8 I/O enabled.

Chris Jones cjns1989 at gmail.com
Sat Sep 19 08:02:05 PDT 2009


On Sat, Sep 19, 2009 at 05:12:08AM EDT, Kalle Olavi Niemitalo wrote:

[..]

> I tried with xterm 235 running on Debian, X11 2.4.0 from
> xquartz.macosforge.org running on Mac OS 10.5.8, and unifont
> 1:5.1.20080914-1 from Debian installed on the Mac.
> 
> printf "abcdefgh\r\xE7\x89\xB9\xE5\x88\xA5XY\n" should display two
> fullwidth CJK characters (U+7279 U+5225) followed by "XYgh".  However,
> the CJK characters get drawn as too narrow, taking up only two and a
> half character cells together, instead of four; all of the "d" and
> part of the "c" remain visible.  If I then select the line with the
> mouse, xterm redraws it in the expected way.

Recreated on my system & does not happen with rxvt-unicode, but I’m not
convinced that’s all there is to it. 

> So, there seems to be an incompatibility between xterm and this
> font, before ELinks is even started.  I don't think it'll be
> useful to look for a bug in ELinks until that has been fixed.

I’ll see if I can reach out to the xterm maintainer. Could be a known
limitation of my version of xterm.

In the meantime, I ran another test to see if I could get this to work
with a different emulator in the following context:

$ uname -a
...  2.6.26-1-686 #1 SMP Fri Mar 13 18:08:45 UTC 2009 i686 GNU/Linux

$ dpkg -l xorg
ii xorg             1:7.3+18       X.Org X Window System

$ dpkg -l rxvt-unicode
ii  rxvt-unicode    9.05-1+lenny1  .. emulator with Unicode support

[Not really watertight, but to be on the safe side, I ran my tests under
a newly-created user so as to try to keep things separate from my usual
environment - no elinks config file, X resource file.. etc.]

I did the following:

1. Started rxvt with the unicode version of the terminus font¹
2. Fired up ELinks v0.12pre5
3. Verified that ELinks had set the charset to UTF-8 Unicode
4. Checked 16 colors and UTF-8 I/O under "Terminal Options"
5. Pointed ELinks to http://www.alanwood.net/unicode/hebrew.html

Upon scrolling, I experienced the same character “remanence” in random
places as described in my previous report.

I also noted the “tearing” effect with the terminal’s black background
showing through ELinks’ white background.

As before, Ctrl-L eliminated the artifacts, except for the black spots. 

I tried rxvt + unifont with similar results.

Are you able to view this particular page without problems? 

If so, please let me know what emulator and font I should be using.

Thanks,

CJ

¹ $ rxvt-unicode -fn "-xos4-terminus-medium-r-normal–12-120-72-72-c-60-iso10646-1" +sb -fg white -bg black



More information about the elinks-users mailing list