[elinks-users] SSL Error accessing self signed site, always ask user confirmation

Douglas Drumond drumond.douglas at gmail.com
Wed Feb 3 10:38:07 PST 2010


Hi,

When I use elinks to access a self-signed site, for every page I try
to see, I get message
"Unable to retrieve https://dfd-desktop/page_name:
SSL Error"

I tried with localhost instead of machine name and got same message.

In fact, it retrieves the content, but issues this message every page.

I couldn't find a way to force elinks to accept the certificate and
stopping complaining about SSL.

This is my configuration:

$ elinks -version
ELinks 0.12pre5
Built on Oct 20 2009 09:31:29

Features:
Standard, IPv6, gzip, bzip2, UTF-8, Periodic Saving, Viewer (Search
History, Timer, Marks), Cascading Style Sheets, Protocol
(Authentication, File, CGI, Finger, FTP, HTTP, URI rewrite, User
protocols), SSL (GnuTLS), MIME (Option system, Mailcap, Mimetypes
files), LED indicators, Bookmarks, Cookies, Form History, Global
History, Scripting (Lua, Perl, Ruby), Goto URL History


Running on Ubuntu Karmic 32 bits (elinks from Ubuntu repository)


I generated the certificate following instructions from:
https://help.ubuntu.com/9.10/serverguide/C/certificates-and-security.html

Also tried:
https://help.ubuntu.com/community/OpenSSL


My elinks.conf has just one line:
set connection.ssl.cert_verify = 0

Is there a way to force elinks to not complain about SSL Error?
Maybe one message first time I access the site (or, at most, one
per session), instead of one per hit.

Thanks in advance,

Douglas Drumond



More information about the elinks-users mailing list