[elinks-users] Ctrl-S fails to bind

Dun Peal dunpealer at gmail.com
Mon Dec 16 20:51:37 PST 2013


Thanks, Chris. I just tried, and it doesn't look like it's the
terminal capturing Ctrl-S. I issues "Ctrl-V Ctrl-S" and didn't get the
dialog either.

I should mention another issue I saw, where making changes to the
elinks.conf file did not apply in the application as I subsequently
launched it. The only way to apply those changes was to launch "Setup
-> Options Manager", then apply the changes there, and exit.

This is the first keybindings change I've tried, perhaps there is a
similar problem with it?

On Mon, Dec 16, 2013 at 8:06 PM, Chris Jones <cjns1989 at gmail.com> wrote:
> On Mon, Dec 16, 2013 at 09:17:59PM EST, Dun Peal wrote:
>
>> I added the following line to my ~/.elinks/elinks.conf:
>>
>>     bind "main" "Ctrl-S" = "save-formatted"
>>
>> Unfortunately, it doesn't bind; hitting Ctrl-s repeatedly fails to
>> launch the "save-formatted" dialog.
>>
>> This is ELinks 0.12pre5 from the official repos of Ubuntu 13.04.
>
>> Should I report this as a bug, or am I at fault and doing something
>> wrong?
>
> Probably ELinks never sees your CTRL-S.. the underlying terminal grabs
> it and does not pass it to the application.
>
> But then hitting CTRL-S should freeze your terminal and you'd need to
> issue a CTRL-Q to unfreeze... so I'm not sure..
>
> See "man stty".
>
> You could try to issue a
>
> | % stty CTRL-V CTRL-S ''
>
> before you launch ELinks and see if it helps.
>
> .. or if you don't want to bother about stty, you could also hit "CTRL-V
> CTRL-S" in ELinks (instead of just CTRL-S) .. and ELinks should see the
> CTRL-S.
>
> IOW, CTRL-V is akin to an escape character in this context.
>
> CJ
>
> --
> Alex Perez is aliveeeeeeee!!!
> _______________________________________________
> elinks-users mailing list
> elinks-users at linuxfromscratch.org
> http://linuxfromscratch.org/mailman/listinfo/elinks-users



More information about the elinks-users mailing list